db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod_Thapliyal" <Vinod_Thapli...@infosys.com>
Subject Do I need to define a DAtabaseMAP if I am connecting to two databases.
Date Tue, 11 Feb 2003 06:35:51 GMT
Hi,

I have deployed Jetspeed as an application on my tomcat server. My default database is Hypesonic.
I am using my Oracle database also. Which I have configured as a second database. My problem
is that when I am querying using the Database browser portlet on my oracle table no results
are returned.

1. Do I need to define manually a databasemap for my Oracle Database or it will be automatically
generated for me. I don't think I should generate it manually then I will need to update my
torque.jar file?

2.
The settings in my torque.properties are as follows:


torque.database.default=default
torque.database.default.adapter=hypersonic


torque.database.vinod=vinod
torque.database.vinod.adapter=oracle

##
## Using torque's old pool
##
torque.dsfactory.default.connection.driver = org.hsqldb.jdbcDriver
torque.dsfactory.default.connection.url = jdbc:hsqldb:${webappRoot}/WEB-INF/db/jetspeed
torque.dsfactory.default.connection.user = sa 
torque.dsfactory.default.connection.password = 

torque.dsfactory.default.factory=org.apache.torque.dsfactory.TorqueDataSourceFactory
# The number of database connections to cache per ConnectionPool instance (specified per database)
torque.dsfactory.default.pool.defaultMaxConnections=10
torque.dsfactory.default.pool.maxExpiryTime=3600
torque.dsfactory.default.pool.connectionWaitTimeout=10
### MySQL
### torque.dsfactory.default.connection.driver = org.gjt.mm.mysql.Driver
### torque.dsfactory.default.connection.url = jdbc:mysql://localhost:3306/jetspeed
### torque.dsfactory.default.connection.user =  root
### torque.dsfactory.default.connection.password = 
### Oracle
 torque.dsfactory.vinod.connection.driver = oracle.jdbc.driver.OracleDriver
 torque.dsfactory.vinod.connection.url = jdbc:oracle:thin:@triveni:1521:galileo
 torque.dsfactory.vinod.connection.user =  turbine
 torque.dsfactory.vinod.connection.password = turbine


Can't figure out whats wrong?

Mime
View raw message