db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Lustig" <m...@marclustig.com>
Subject AW: IDBroker /ID_TABLE problem
Date Tue, 14 Jan 2003 11:14:25 GMT
There is a maven-target torque:insert-sql
But I'm not quite sure whether this processes the inserts for id_table as
well.
Also, I wonder what happens if I recreate the sql with new tables.
Can I just insert all the id_table entries once again and overwrite the old
rows?
Or does this cause trouble for the IDBroker?
When I create a new table what I did was only inserting the inserts for the
new table.
It is necessary then to replace the primary key with the next one available
in my existing id_table. That I find a bit annoying.

Marc

> -----Urspr√ľngliche Nachricht-----
> Von: Dan Tran [mailto:danttran@hotmail.com]
> Gesendet: Dienstag, 14. Januar 2003 00:33
> An: Turbine Torque Users List
> Betreff: Re: IDBroker /ID_TABLE problem
>
>
> I have complained about this before, but the answer is your  have to write
> your own script to prepopulate id_table.  I find it very annoying
>
> Is this a bug?
>
> -D
> ----- Original Message -----
> From: "Marc Lustig" <mail@marclustig.com>
> To: "Turbine Torque Users List" <turbine-torque-user@jakarta.apache.org>
> Sent: Monday, January 13, 2003 1:06 AM
> Subject: AW: IDBroker /ID_TABLE problem
>
>
> >
> >
> > > -----Urspr√ľngliche Nachricht-----
> > > Von: Peter Courcoux [mailto:peter@courcoux.biz]
> > > Gesendet: Montag, 13. Januar 2003 01:57
> > > An: Turbine Torque Users List
> > > Betreff: Re: IDBroker /ID_TABLE problem
> > >
> > >
> > > Marc,
> > >
> > > When you run ant init it should create the id_table which I suspect it
> > > does. It should also then run an ant target to insert into
> the id_table
> > > a line for each of the tables in your schema.
> >
> > I'm using Maven for building (which should be no difference to
> using ant,
> > since the torque-plugin-goals is just wrapped around the ant targets)
> > Then I trigger torque:id-table-init-sql maven reports BUILD SUCCESSFUL,
> but
> > still no data is put into my id_table?
> >
> > Any further suggesstion ?
> >
> > Thanks!
> > Marc
> >
> >
> > --
> > To unsubscribe, e-mail:
> <mailto:turbine-torque-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:turbine-torque-user-help@jakarta.apache.org>
> >
>
> --
> To unsubscribe, e-mail:
<mailto:turbine-torque-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:turbine-torque-user-help@jakarta.apache.org>


Mime
View raw message