db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Fortytwo <...@ign.com>
Subject timestamp is being truncated
Date Tue, 28 Jan 2003 21:52:55 GMT
When I save timestamps, the values are truncated to dates.

The field declaration in the schema is:
   <column 
name="whenAdded"   javaName="WhenAdded"   required="false"  type="TIMESTAMP"/>
when I set the timestamp I do:
   profile.setWhenAdded( new java.sql.Timestamp(System.currentTimeMillis()) );
I've also tried
   profile.setWhenAdded( new java.sql.Date(System.currentTimeMillis()) );
and
   profile.setWhenAdded( new java.util.Date(System.currentTimeMillis()) );

No matter what, the date is saved to the database with the time truncated 
so that only the date part of the timestamp is saved.

I've put trace statements into the code and the value is definitely a 
timestamp before and after I save the record, but when the record is 
reloaded it's truncated. If I look at the value directly in the database, 
it's always truncated after I insert it with torque. If I do the same 
insert using a sql INSERT statement it saves the time in the field, so 
there isn't anything in the database that's forcing the truncation.

I'm using Oracle with Torque 3.0. I tried tracing the code through the 
entire insert, but I get to the point where it goes into village and I 
don't have that code. I suppose I could download it, but I'm not sure I can 
figure this out. Does anyone have any ideas?


Mime
View raw message