db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Keene <rich...@asgnetwork.com>
Subject Re: Help with ant build of Torque files.
Date Tue, 28 Jan 2003 17:17:23 GMT
Turns out the Ant has changed in how it uses classpath.  Here is a quote 
from the WhatsNew file...

* The Classloader usage has been changed for the taskdef, property, 
available
  and sql tasks so that it delegates to the parent classloader. This may 
cause
  ClassNotFoundExceptions to be thrown if a system class attempts to load a
  class in the taskdef's classpath (typically factory objects).

Which is exactly what I am seeing. :-(
Now I need to figure out how to work around this.  I may have to add the 
.jar's to the CLASSPATH
on my machine.

Richard Keene wrote:

> I got the latest Torque to try out.  When I run the build script,
> build-torque.xml, I get...
> WEB-INF/build-torque.xml [75] taskdef class 
> org.apache.torque.task.TorqueDataModelTask cannot be found
>
> I have tried lots with the classpath and extensively studied the 
> build-torque.xml file.
>
> At the  lines
>   <taskdef
>     name="torque-data-model"
>     classpathref="torque-classpath"
>     classname="org.apache.torque.task.TorqueDataModelTask"/>
>
> is where it fails.
>
> I tried
>   <taskdef
>     name="torque-data-model"
>     classpath="lib"
>     classname="org.apache.torque.task.TorqueDataModelTask"/>
>
> and
>   <taskdef
>     name="torque-data-model"
>     classpath="C:/ProjManager/WEB-INF/lib"
>     classname="org.apache.torque.task.TorqueDataModelTask"/>
>
> And als tried the above with the torque-3.0-rc2.jar file unpacked in 
> the lib directory.  I also tried running with ant external to NetBeans 
> IDE.
>
> HELP!
>
> (I have a senior manager breathing down by neck on this one...)



-- 
Richard Keene
801-647-8932
richard@asgnetworks.com




Mime
View raw message