db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Walt Armour <Wa...@concur.com>
Subject RE: timestamp is being truncated
Date Wed, 29 Jan 2003 20:45:34 GMT
We ran into this also.  I don't have all the details handy but I think it
went something like this:

We passed in a timestamp at some level.  It got converted into a
java.util.Date.  That got passed down through Torque and into Village.
Village converted it to a java.sql.Date (as opposed to java.sql.Timestamp).
Something after this (possibly the Oracle JDBC driver) considers it just a
date and whacks any timestamp portion (if there even is any at this point).

So it looks like a fix would need to occur at the village level.

> -----Original Message-----
> From: Geoff Fortytwo [mailto:g42@ign.com] 
> Sent: Tuesday, January 28, 2003 1:53 PM
> To: turbine-torque-user@jakarta.apache.org
> Subject: timestamp is being truncated
> 
> 
> When I save timestamps, the values are truncated to dates.
> 
> The field declaration in the schema is:
>    <column 
> name="whenAdded"   javaName="WhenAdded"   required="false"  
> type="TIMESTAMP"/>
> when I set the timestamp I do:
>    profile.setWhenAdded( new 
> java.sql.Timestamp(System.currentTimeMillis()) );
> I've also tried
>    profile.setWhenAdded( new 
> java.sql.Date(System.currentTimeMillis()) );
> and
>    profile.setWhenAdded( new 
> java.util.Date(System.currentTimeMillis()) );
> 
> No matter what, the date is saved to the database with the 
> time truncated 
> so that only the date part of the timestamp is saved.
> 
> I've put trace statements into the code and the value is definitely a 
> timestamp before and after I save the record, but when the record is 
> reloaded it's truncated. If I look at the value directly in 
> the database, 
> it's always truncated after I insert it with torque. If I do the same 
> insert using a sql INSERT statement it saves the time in the 
> field, so 
> there isn't anything in the database that's forcing the truncation.
> 
> I'm using Oracle with Torque 3.0. I tried tracing the code 
> through the 
> entire insert, but I get to the point where it goes into 
> village and I 
> don't have that code. I suppose I could download it, but I'm 
> not sure I can 
> figure this out. Does anyone have any ideas?
> 
> 
> --
> To unsubscribe, e-mail:   
> <mailto:turbine-torque-user-> unsubscribe@jakarta.apache.org>
> 
> For additional commands, 
> e-mail: <mailto:turbine-torque-user-help@jakarta.apache.org>
> 

Mime
View raw message