db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim O'Quinn <oqu...@dev-null.com>
Subject ant -f build-torque.xml om
Date Thu, 19 Dec 2002 18:53:11 GMT
I'm so close!  I'm trying to generate my class files from the database, 
but I seem to be missing something.  When I run 'ant -f build-torque.xml 
*om*' it grinds away for a few seconds then generates a zero lengh 
'.om.generation' file. 

I have a build.properties file in my directory and it seems to find some 
properties.

The velocity.log file says:  [error] RHS of #set statement is null. 
Context will not be modified. om/Control.vm [line 4, column 1] 

The line in om/Control.vm is  #set ( $dbprops = 
$properties.load("sql/base/$targetDatabase/db.props") )

The db.props file is in 'templates/base/postgresql'.

Any idea what is missing or what I'm doing wrong?

Thanks,

Jim


[oquinn@chato torque-3.0]$ ant -f build-torque.xml  om
Buildfile: build-torque.xml

check-use-classpath:

check-run-only-on-schema-change:

om-check:

om:
     [echo] +------------------------------------------+
     [echo] |                                          |
     [echo] | Generating Peer-based Object Model for   |
     [echo] | YOUR Torque project! Woo hoo!            |
     [echo] |                                          |
     [echo] +------------------------------------------+

om-classpath:

om-template:
[torque-data-model] Using contextProperties file: 
/home/oquinn/cns/java/torque-3.0/build.properties
[torque-data-model] *Cannot get default properties!*
[torque-data-model] Generating to file 
/home/oquinn/cns/java/torque-3.0/src/java/report.cns_test.om.generation

BUILD SUCCESSFUL
Total time: 8 seconds


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message