db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Emminger <e...@ericemminger.com>
Subject Re: addAscendingOrderBy problem
Date Wed, 18 Dec 2002 00:43:11 GMT
Prescott

I'm not exactly sure what to tell you. I tried your schema with Torque
3.0 (the production release) inside a Turbine app. It worked and no
exceptions were thrown.

Here's the code I used.

----- Java code -----
        List list = null;
        Criteria crit = new Criteria();
        crit.add(RuntypePeer.RUNNERID, 2);
        crit.addAscendingOrderByColumn(RuntypePeer.RUNTYPE);
        crit.addAscendingOrderByColumn(RuntypePeer.RUNTYPEID);
        Log.debug("order by columns: " +
crit.getOrderByColumns().toString());
        Log.debug("order by size: " + crit.getOrderByColumns().size());
        Log.debug("crit: " + crit.toString());
        try
        {
            list = RuntypePeer.doSelect(crit);
        }
        catch (TorqueException te)
        {
            list = null;
            Log.error("Could not select runtypes: " + te.toString());
            te.printStackTrace();
        }
----- Java code -----

Could Torque be configured incorrectly in your app? I've only used
Torque within Turbine, so I'm not familiar with all the settings. If
you're sure the setup is correct, then it may relate to your specific
setup. In that case, file a bug in Scarab. The Torque developers will be
more helpful than I.

> No problem.  Here's the schema.  I'm a pretty serious runner and I've
> written a Java app that manages all my training data.  I started it
> long ago with InstantDB but the thing fell apart with a bit of data in
> it.  I switched to using Torque and MySQL and all was going well until
> the 3.0 release and this problem.

I'm curious. How often and how far do you run?

Eric

-- 
Eric Emminger
eric@ericemminger.com


Mime
View raw message