db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JDigg...@genelogic.com
Subject Re: Oracle CLOBs return null
Date Tue, 10 Dec 2002 22:55:09 GMT

Hm, informative link, thank you. I'll check into this in a moment though I
just found something that might be causing other problems I've been having,
as well (i.e. the idmethod='native' not _ever_ working). In the
Torque.properties file built by the tdk2.2 the string:


is left in the file. I'm not quite certain why this isnt' updating itself
to 'oracle' but I can imagine if torque thinks it's working on a mysql
database then anything outside of SQL92 might definitely screw up
(including sequences and clobs, etc). Can anyone comment on why this
parameter might've been left as 'mysql' even though in the build.properties
file I've correctly defined:

database = oracle


databaseDriver = oracle.jdbc.OracleDriver

Any help is greatly appreciated; Gabor, my thanks for the pointers.

                      Gabor Kincses                                                      
                      <npure2001@yahoo.        To:       Turbine Torque Users List    
                      com>                      <turbine-torque-user@jakarta.apache.org>
                      12/10/2002 04:20         Subject:  Re: Oracle CLOBs return null    
                      Please respond to                                                  
                      "Turbine Torque                                                    
                      Users List"                                                        

I doubt this is a problem with torque.

I have seen something quite similar with the Oracle
JDBC driver about 2 years ago.  Even the examples in
the OTN tutorial didn't work right.  This was somewhat
correlated to the version of the download (8.0.5 vs.
8.1.6).  These are of course engine release numbers,
but stupidly the driver downloads were tied to these.
Also, code that worked with 8.0.5 didn't work with
8.1.6.  I think I always used the type-4 version (no
type-2 on FreeBSD :().  Have you tried the type-2
version of the driver?

You may want to compare the SQL that torque issues to
some of the success stories like this:


--- JDiggans@genelogic.com wrote:
> If any of the fields in my model are marked as CLOBs
> Torque seems to return
> null when running a select for these fields. I found
> this link in the
> archive:

> stating that the solution is to, instead, mark all
> fields. Is this really the case? If so, why? Nothing
> in the archives seems
> to explain Torque's issue w/ Oracle CLOBs ... can
> anyone elaborate?
> Regards,
> -j
> -------------------------------------------------
> James Diggans
> Bioinformatics Programmer
> Gene Logic, Inc.
> Phone: 301.987.1756
> FAX: 301.987.1701
> --
> To unsubscribe, e-mail:
> For additional commands, e-mail:
> <mailto:turbine-torque-user-help@jakarta.apache.org>

Gabor Kincses
Running FreeBSD 4.7-RELEASE and Mandrake Linux 8.1

View raw message