db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fox <thomas....@seitenbau.com>
Subject Re: change name of retrieveByPks method to retrieveByObjectKeys?
Date Tue, 22 Sep 2015 07:37:16 GMT
Thanks, Greg. This seems a good way to go, I will do this.
 
    Thomas

Greg Monroe wrote:

This seems like it might have an impact on existing code.

Any reason not to deprecate the existing methods and go with 
retrieveByObjectPKs  and retrieveByIntegerPKs?  This would define a 
clear naming convention for any future convenience method.. e.g. 
retrieveByStringPKs and the like.

On 9/19/15 5:02 PM, Thomas Fox wrote:
> Hi,
>
> for
> https://issues.apache.org/jira/browse/TORQUE-334
> I'd like to change the name of the existing retriebeByPks methods to retrieveByObjectKeys.
>
> Any objections or better ideas ?
>
> Example:
> BaseBookPeer now has 2 methods:
>
> public static List<Book> retrieveByPKs(Collection<ObjectKey> pks);
> public static List<Book> retrieveByPKs(Collection<ObjectKey> pks, Connection
dbcon);
>
> These methods would be renamed to
>
> public static List<Book> retrieveByObjectKeys(Collection<ObjectKey> pks);
> public static List<Book> retrieveByObjectKeys(Collection<ObjectKey> pks,
Connection dbcon);
>
> to be able to add the following methods (which would have the same erasure as the unrenamed
methods)
>
> public static List<Book> retrieveByPKs(Collection<Integer> pks);
> public static List<Book> retrieveByPKs(Collection<Integer> pks, Connection
dbcon);
>
>     Thanks,
>
>        Thomas
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-dev-help@db.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message