db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Vandahl ...@apache.org>
Subject Re: change name of retrieveByPks method to retrieveByObjectKeys?
Date Sun, 20 Sep 2015 19:05:25 GMT
On 19.09.15 23:02, Thomas Fox wrote:
> Hi,
> 
> for 
> https://issues.apache.org/jira/browse/TORQUE-334
> I'd like to change the name of the existing retriebeByPks methods to retrieveByObjectKeys.
> 
> Any objections or better ideas ?
> 
> Example:
> BaseBookPeer now has 2 methods:
> 
> public static List<Book> retrieveByPKs(Collection<ObjectKey> pks);
> public static List<Book> retrieveByPKs(Collection<ObjectKey> pks, Connection
dbcon);
> 
> These methods would be renamed to
> 
> public static List<Book> retrieveByObjectKeys(Collection<ObjectKey> pks);
> public static List<Book> retrieveByObjectKeys(Collection<ObjectKey> pks,
Connection dbcon);
> 
> to be able to add the following methods (which would have the same erasure as the unrenamed
methods)
> 
> public static List<Book> retrieveByPKs(Collection<Integer> pks);
> public static List<Book> retrieveByPKs(Collection<Integer> pks, Connection
dbcon);

+1
Go ahead.

Bye, Thomas.



---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message