db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Monroe <mon...@nc.rr.com>
Subject Re: Change JDK requirements for Torque 4.1
Date Tue, 08 Sep 2015 13:42:20 GMT
+1

I think the logic for Java 1.5 was that some Linux distro's only offered 
this and some people were locked into distro only versions. I think all 
the supported Linux distro's provide at least 1.7.  So people locked 
into distro versions only by their IT rules should have Java 1.7 available.

On 9/4/15 9:41 PM, Thomas Fox wrote:
> Hi,
>
> for fixing https://issues.apache.org/jira/browse/TORQUE-226, a version of jgit must be
included which requires JDK 1.7 for the generator.
> I suggest to raise the required JDK version for the Torque 4.1 generator to JDK 1.7
>
> Also, it has become difficult to run a JDK 1.5 build on the Apache builds server. See
the failed runs of https://builds.apache.org/job/torque4-test-project-derby/ which were fixed
by raising the target JDK.
> Therefore, I suggest to raise the required JDK version for the Torque 4.1 Runtime (and
thus the rest of Torque except the generator and the maven plugin) to JDK 1.6
>
> Please object if there are any problems with this.
>
>      Thomas
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-dev-help@db.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message