db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Fox (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TORQUE-316) saveMethods.vm has toSave.setNew instead of a using toSaveVariableWithDot
Date Sat, 16 Aug 2014 00:38:20 GMT

    [ https://issues.apache.org/jira/browse/TORQUE-316?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14099402#comment-14099402
] 

Thomas Fox commented on TORQUE-316:
-----------------------------------

To reproduce the problem, torque.om.complexObjectModel=false must also be added in the torque-gen
properties file


> saveMethods.vm has toSave.setNew instead of a using toSaveVariableWithDot
> -------------------------------------------------------------------------
>
>                 Key: TORQUE-316
>                 URL: https://issues.apache.org/jira/browse/TORQUE-316
>             Project: Torque
>          Issue Type: Bug
>          Components: Templates
>    Affects Versions: 4.0
>            Reporter: Rob Decker
>            Priority: Critical
>
> When I generate classes with 
> torque.om.addSaveMethods=true
> torque.om.saveMethodsInDbObjects=true
> The dbobjects won't compile because the line toSave.setNew(false) is not a variable.
I updated the saveMethods.vm template to fix the issue with this:
> diff torque-templates-4.0-new/org/apache/torque/templates/om/templates/general/saveMethods.vm
torque-templates-4.0-orig/org/apache/torque/templates/om/templates/general/saveMethods.vm
> 65c65
> <                     ${toSaveVariableWithDot}setNew(false);
> ---
> >                     toSave.setNew(false);



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message