db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Monroe <gmon...@apache.org>
Subject Re: [VOTE]release torque 4.0
Date Fri, 01 Mar 2013 22:09:45 GMT
I've found some "edge case" problems but I don't think they are show 
stoppers.
So my vote is:

[x]  +1 yes

The worst of these is that it doesn't work with MS SQL Server 2005.   
The Date
column type does not exist in MS Server until the 2008 version. SQL 2005
does not have an end of life until 2016, so there may be some people who
still use this.

Interestingly enough, the Derby networked server fails some tests while the
embedded test works.

Also, I ran thru all the Tutorials (ORM MVN and Ant, GEN) and found no
problems except for the offline docs did not contain the *.xsd schema
files.

Here are my testing notes:

Torque 4.0 Notes

Environment:  Window 7, Java 1.6.0_38-b05, Maven 2.2.1

SVN Checkout / Rebuild:  OK

Test Project Runs:

   MySQL  (MySql V5.1):  OK

   MS SQL (MS SQLServer 2005):  Failed

     SQL Execution
       DATE column type not supported

   Derby Embedded (10.8.3.0 ) OK

   Derby 10.8.3.0 (Networked version):   Failed

     Test set: 
org.apache.torque.generated.peer.DefaultValuesFromDatabaseTest
       testNewObjectDatabaseDefault:
         The syntax of the string representation of a datetime value is 
incorrect.

       testNewObjectChangedValue
         The syntax of the string representation of a datetime value is 
incorrect.

      Test set: org.apache.torque.util.ExceptionMapperTest
        testTransactionDeadlock
         autocommit must be set to false for this test

   Derby 10.9.1.0 (Networked version):   Failed

     Test set: 
org.apache.torque.generated.peer.DefaultValuesFromDatabaseTest
       testNewObjectDatabaseDefault:
         The syntax of the string representation of a datetime value is 
incorrect.

       testNewObjectChangedValue
         The syntax of the string representation of a datetime value is 
incorrect.

      Test set: org.apache.torque.util.ExceptionMapperTest
        testTransactionDeadlock
         autocommit must be set to false for this test


Documentation Bundle (Site):

   - Missing database-4.0*.xsd files in orm-reference directory

ORM - Tutorial
   MVN - OK
   ANT - OK
     NOTE:  Combination of MySQL 5.1 and Connector 5.1.9 generated a
            "org.gjt.mm.mysql.Driver is not supported by DataSource".  
Needed
            to downgrade to 5.0.9 (Maven dependancy version).

Gen - Tutorial
    MVN - OK


On 2/27/2013 3:56 PM, Thomas Fox wrote:
> Should the artifacts staged at
> https://repository.apache.org/content/repositories/orgapachetorque-308/
> built from svn tag
> https://svn.apache.org/repos/asf/db/torque/torque4/tags/torque-4.0
> , rev 1450611, be released as torque-4.0 ?
>
> overall source distribution (all modules):
> https://repository.apache.org/content/repositories/orgapachetorque-308/org/apache/torque/torque/4.0/torque-4.0-source-release.zip
>
>
> [ ] +1 yes
> [ ] 0 Abstain
> [ ] -1 No (please give reason)
>
> The vote closes Sun, 3 Mar, 18:00 GMT
>
>      Thomas
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-dev-help@db.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message