db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Fox (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (TORQUE-216) Rename class DB to Adapter
Date Tue, 24 Jul 2012 15:49:35 GMT

     [ https://issues.apache.org/jira/browse/TORQUE-216?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Thomas Fox resolved TORQUE-216.

    Resolution: Fixed
> Rename class DB to Adapter
> --------------------------
>                 Key: TORQUE-216
>                 URL: https://issues.apache.org/jira/browse/TORQUE-216
>             Project: Torque
>          Issue Type: Improvement
>          Components: Runtime
>            Reporter: Thomas Fox
>            Assignee: Thomas Fox
>             Fix For: 4.0-beta1
> Currently, the word "Database" is quite overloaded in Torque. It means the name of the
database (as in Torque.getDefaultDB()) as well as the information about a particular database
(as in the class Database).
> To add to the confusion, there is also the class name org.apache.torque.adapter.DB which
holds the interface for a database adapter for the runtime.
> That class name should be changed to"Adapter".
> Also, all methods to retrieve an adapter but are named "DB" (as in Torque.getDB()) should
be deprecated; and new methods which are named "Adapter" (as Torque.getAdapter()) should be

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

View raw message