db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fox <Thomas....@seitenbau.net>
Subject change the class name of the DB interface to Adapter ?
Date Wed, 27 Jun 2012 02:39:03 GMT

Currently, the word "Database" is quite overloaded in Torque. It means the
name of the database (as in Torque.getDefaultDB()) as well as the
information about a particular database (as in the class Database).
To add to the confusion, there is also the class name
org.apache.torque.adapter.DB which holds the interface for a database
adaptor for the runtime.
I'd propose to resolve that confusion by changing that class name to
"Adapter".
Also, deprecate all methods to retrieve an adapter but are named "DB" (as
in Torque.getDB()); and add new methods which are named "Adapter" (as
Torque.getAdapter()).

Any objections, comments, suggestions ?

    Thomas


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message