db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fox <Thomas....@seitenbau.net>
Subject Re: Change semantics of Criteria.add() and Criteria.or()
Date Sun, 15 Jan 2012 14:29:15 GMT

> Thomas Vandahl wrote:
> On 27.12.11 10:46, Thomas Fox wrote:
> > On checking the test, I discovered that there is a "valid" use case for
> > String column namnes even if one uses the generated code, namely
aliases.
>
> I don't know what exact use case you have in mind but I propose to
> provide a method to create a Column object for aliases

This method already exists: new org.apache.torque.ColumnImpl(String).

> and remove the
> string-based methods altogether.

I'd rather leave them in. Having methods which take a String object feels
"lightweight" and "simple" for users, and besides they do not add much
complexity (Basically calling new ColumnImpl(String) in each of them).
I do not have a very strong opinion here, if both Greg and you insist I'll
take them out.

     Thomas


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message