db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fox <Thomas....@seitenbau.net>
Subject Re: Change semantics of Criteria.add() and Criteria.or()
Date Tue, 27 Dec 2011 09:46:59 GMT
I just committed the new Criteria class, ready for inspection.
On checking the test, I discovered that there is a "valid" use case for
String column namnes even if one uses the generated code, namely aliases.
So I decided to leave the method staking String column names in the new
Criteria object. This leaves the new object larger than 2000 lines, but
once all deprecated methods are removed, it will be less than 2000 lines.
In my opinion, this is ok.
Please speak up now if you are of the opinion that the methods taking
string column names should be removed, this can still be done now.

Next step would be to change the templates to create methods which use the
new Criteria class. Up to now, only the old class is used so the new class
is pretty useless.
My current idea is to cretae two build options

# creates methods which take the old org.apache.torque.util.Criteria object
# creates methods which take the new org.apache.torque.criteria.Criteria

In my opinion, the default value of both options should be true. What do
you think ?


To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

View raw message