db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Vandahl ...@apache.org>
Subject Re: Change semantics of Criteria.add() and Criteria.or()
Date Wed, 28 Dec 2011 13:43:09 GMT
On 27.12.11 10:46, Thomas Fox wrote:
> On checking the test, I discovered that there is a "valid" use case for
> String column namnes even if one uses the generated code, namely aliases.

I don't know what exact use case you have in mind but I propose to
provide a method to create a Column object for aliases and remove the
string-based methods altogether.

> # creates methods which take the old org.apache.torque.util.Criteria object
> torque.use.util.criteria
> # creates methods which take the new org.apache.torque.criteria.Criteria
> object
> torque.use.criteria.criteria
> In my opinion, the default value of both options should be true. What do
> you think ?

IMHO, it the time for radical changes is now. So I suggest to support
only one flag to switch using either the old or the new class but not both.

Bye, Thomas.

To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

View raw message