db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mrab <michele.raba...@nscorp.com>
Subject Re: Torque 3.1.1 - change database url based on env (QA, TEST, etc.)
Date Thu, 20 Oct 2011 12:33:37 GMT



mrab wrote:
> 
> 
> About the upgrade to 3.3, what are the steps for that?
> 
> This is what I have done:
> 
> 1) Added maven-torque-plugin-3.3 directory to /.maven/cache
> 2) Added torque-gen-templates-3.3.jar, torque-gen-3.3.jar, torque-3.3.jar
> to /.maven/repository/torque/jars
> 3) Added maven-torque-plugin-3.3.jar to /.maven/repository/torque/plugins
> 4) Changed the 3.1.1 references in project.xml to 3.3
> 5) Removed the 3.1.1 directory, jars, plugins
> 6) Removed the target directories from my application 
> 7) Ran 'maven java:compile'
> 8) Got 'build failed' because of unsatisfied dependency
> 'torque:maven-torque-plugin:3.1.1:plugin'
> 9) Added the 3.1.1 stuff back in
> 10) Removed the target directories from my application
> 11) Ran 'maven java:compile'
> 12) Got 100 deprecation warnings on getMapBuilder and doDelete in BasePeer
> (still using 3.1.1, but why?)
> 13) Tried changing the dtd statement on my schema.xml file from 3_1 to
> 3_3, but that led to connection errors
> 
> What have I missed?
> 
> 

Still trying to resolve this... I did discover files in the directory for
maven-turbine-plugin-1.3 that were looking at Torque 3.1: project.xml,
application-schema.xml, id-table-schema.xml, turbine-security-schema.xml. 
Also, plugin.properties still had turbine.app.flavor = turbine-2.3.2 so I
change it to 2.3.3.

Now when I try 'maven -e torque:om' I get:
Errors stack :
>> Unable to obtain goal [torque:om]
>> File......
>> file:/home/ud177/.maven/cache/maven-torque-plugin-3.3/plugin.jelly
>> Element... torque-data-model
>> Line...... 292
>> Column.... 49
>> org.apache.torque.engine.EngineException: java.net.ConnectException:
>> Connection refused
>> java.net.ConnectException: Connection refused
>> Connection refused

Since I didn't have this problem with 3.1, what is different about Torque
3.3 with the connections?  

Thanks!
Michele


-- 
View this message in context: http://old.nabble.com/Torque-3.1.1---change-database-url-based-on-env-%28QA%2C-TEST%2C-etc.%29-tp32503962p32689238.html
Sent from the Apache DB - Torque Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message