db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Fwd: [GUMP@vmgump]: Project turbine-core (in module turbine-core) failed
Date Fri, 01 Apr 2011 04:05:58 GMT
On 2011-03-31, Thomas Vandahl wrote:

> CCed to torque-dev for Thomas Fox to know.

> On 31.03.11 16:32, Stefan Bodewig wrote:
>> Gump will hand out the latest Torque jars, i.e.
>> torque-runtime-4.0-alpha1-SNAPSHOT.jar,
>> torque-generator-4.0-alpha1-SNAPSHOT.jar and
>> torque-templates-4.0-alpha1-SNAPSHOT.jar when asked for Torque.  Does
>> the plugin work with these versions?  Which of the jars contains

>>> org.apache.torque.task.TorqueDataModelTask

> It used to be in the Torque generator jar but the Torque generator has
> been rewritten from the ground up by Thomas Fox and probably the plugin
> doesn't know about that.

> Anyhow, Turbine needs the Torque plugin/generator/templates/runtime
> Version 3.3. The current version is not backwards compatible.

That's what I thought.

> What do I have to do to achieve this?

Burn a few goats.

OK, the way Gump works it means Turbine must be built before Torque, so
we must make torque-generator depend on turbine-core (and obviously
remove the torque dependencies from turbine-core).  We'll also need to
check whether any of Turbine's dependencies depend on Torque themselves.

I'll take care of this.

Secondly this means Torque 3.x will be downloaded from Maven central and
put into the local repository.  Given that Torque4 seems to be known to
be incompatible to 3.x (I assume this is intentional) this may be a good
thing so I'd live with it (the alternative would be to use a separate
local repository).

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message