db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <fisc...@seitenbau.net>
Subject Re: [Torque 4] mvn install of templates failes
Date Thu, 07 Oct 2010 13:04:53 GMT
> Hi Thomas,
> ...
> The startElement method is called and reads the following values:
> systemId: http://db.apache.org/torque/4.0/templates/database.xsd
> ressource: ../../xsd/database-4-0.xsd
>
> I found out that adding the references to the configuration fails and
> creates an ConfigurationException:
>
> "resource file
> /home/pcs/projects/software/torque/trunk/torque-templates/src/main/
>
resources/org/apache/torque/templates/om/resources/../../xsd/database-4-0.xsd

> not found"
>
> The xsd is stored actually under
> /home/pcs/projects/software/torque/trunk/torque-templates/src/main/
> resources/org/apache/torque/templates/xsd/database-4-0.xsd
>
> Furthermore I noticed that there is no directory resources under om. But
> creating it did not change anything.

The resource path is correct except that the resources directory does not
exist. I thought I fixed that by cancelling the .. elements against the
previous directories, but apparently not... This will probably need to be
fixed in the generator. If I do not give me feedback soon, keep prodding
me.

Thanks for tracing the error,

    Thomas


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message