db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <fisc...@seitenbau.net>
Subject refactoring names in generator
Date Fri, 14 May 2010 15:20:55 GMT

In the tiscussion about accepting the current generator codebase, it was
suggested that the project name remains "generator". However, in the
current codebase, the project name is "torque-gf" (gf for generation
framework). Also, "Generator" is the name of an interface for a java class
producing thext output.
So to prevent further overloading of the term "generator", the name of this
interface should be changed to something else

I intend to pull this straight this weekend, with the following

"Generator" (interface name of output-producing class and config xml
element name) -> Outlet
"$torqueGf" (velocity variable name) -> "$torqueGen"
gf (package name) -> "generator"

Any objections ? Any better ideas for the class name "Outlet" ?


To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

View raw message