db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From croniccoder <chet0...@yahoo.com>
Subject RE: Update not working
Date Tue, 05 Jun 2007 13:44:44 GMT

Thank you foor response. The table I am trying to update does have a primary
key. I seem to just be using basic torque code, and it isn't working, and
for the life of me, I can't figure out WHY!


Thomas Fischer-11 wrote:
> 
> update is known not to work if your table has no primary key. This might
> be
> the cause of your problem.
> 
> It is encouraged very strongly to use primary keys for all your tables.
> 
>    Regards,
> 
>       Thomas
> croniccoder <chet0264@yahoo.com> schrieb am 05.06.2007 15:22:47:
> 
>>
>> I am trying to update a value in my database, and am using the code
> below.
>> But it doesn't update and I have absolutely NO reason why this isn't
>> working. The database it's updating has a primary key. I am getting an
>> instance of the database entry, then trying to update it with a new
> figure.
>>
>> num.setValue(myString);
>> num.save();
>>
>> --
> 

-- 
View this message in context: http://www.nabble.com/Update-not-working-tf3871748.html#a10969809
Sent from the Apache DB - Torque Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message