db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Fischer (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (TORQUE-65) Test Project Testcase: DataTest.testSubqueries fails with MySQL 4.0
Date Sun, 19 Nov 2006 14:15:38 GMT
     [ http://issues.apache.org/jira/browse/TORQUE-65?page=all ]

Thomas Fischer resolved TORQUE-65.
----------------------------------

    Fix Version/s: 3.3
       Resolution: Fixed

Fixed by checking mysql version, if < 4.1, do not test subselects.

> Test Project Testcase: DataTest.testSubqueries fails with MySQL 4.0
> -------------------------------------------------------------------
>
>                 Key: TORQUE-65
>                 URL: http://issues.apache.org/jira/browse/TORQUE-65
>             Project: Torque
>          Issue Type: Bug
>          Components: Test Project
>    Affects Versions: 3.3
>            Reporter: CG Monroe
>            Priority: Minor
>             Fix For: 3.3
>
>
> MySQL 4.0 does not support subselect (and some other Torque supported DBs).  But the
testSubqueries testcase uses them.  This should not be an error or failure condition.  
> Should this just catch exceptions and print a warning or does there need to be a "support
subselects" option on DBAdaptors (and MySQL 4.0 / 5.0 adaptor)?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message