db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thoralf Rickert (JIRA)" <j...@apache.org>
Subject [jira] Commented: (TORQUE-49) Encoding will not be used in insert-sql if it is used in generation task
Date Sun, 13 Aug 2006 08:23:14 GMT
    [ http://issues.apache.org/jira/browse/TORQUE-49?page=comments#action_12427744 ] 
            
Thoralf Rickert commented on TORQUE-49:
---------------------------------------

Okay, but then is the sql output of torque incorrect because it is generated in the encoding
of the xml schema. My platform encoding is cp1251 or ISO 8859-1 but the xml schema is in UTF-8.
The generated sql output is still in UTF-8 and not converted to cp1251 or ISO 8859-1. 

If Torque should use the current platform encoding for the generated files the "sql" and "om"
tasks are buggy. Both generate files in the encoding of the XML schema file. 

They mix the encoding of the XML file and the encoding of the Torque templates. I'Ve tried
the following test:

 - Add a special ISO-8859-1 character (for example a german umlaut) in the Torque template
(for example Peer.vm)
 - Add a special UTF-8 character (another umlaut) in the UTF-8 encoded XML schema (for example
a table description)
 - Generate the Peers and Objects classes. The description of the table should be added to
the classes comment
 - The generated Peer has a ISO-8859-1 character and a UTF-8 character.

Of course this is a special condition because the torque templates are normally in english
and all characters can be mapped to the ASCII encoding which is a subset of ISO-8859-1 and
UTF-8. So you normally don't have problems with special characters.

But the fact is that torque ignores the encoding of the XML file. It should check the encoding
of the XML file and convert it to the platform encoding (or better to the Torque template
encoding). I had a lot of fun in the last months with character encoding in Java IO. This
isn't trivial if you don't use the current platform encoding. Unicode doesn't help if you
read and write text from/to files and ignore the encoding of them. 



> Encoding will not be used in insert-sql if it is used in generation task
> ------------------------------------------------------------------------
>
>                 Key: TORQUE-49
>                 URL: http://issues.apache.org/jira/browse/TORQUE-49
>             Project: Torque
>          Issue Type: Bug
>          Components: Generator
>    Affects Versions: 3.2
>            Reporter: Thoralf Rickert
>            Priority: Trivial
>
> My schema.xml is encoded in UTF-8 and torque generates a SQL file in UTF-8. But when
I run "insert-sql" the TorqueSQLExec task decodes the file with the system encoding because
it doesn't know that the SQL file was encoded in UTF-8.
> My current solution is to set the attribute encoding="UTF-8" in the "torque-sql-exec"
task call in my build-torque.xml.
> But I think torque should know the encoding of the files that it generates. It could
be set (for example) in the sqldb.map file or by using special filename extension like .utf8.sql

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message