db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <tfisc...@apache.org>
Subject jdk 1.3 support in torque generator
Date Mon, 25 Jul 2005 19:10:23 GMT
Hi,

I am unsure about whether we should still support jdk 1.3.x in the 
generator. If we would drop it, we could also drop the dependencies on 
jndi.jar and jdbc.jar, which are awful as they cannot be obtained from 
ibiblio, but have to be downloaded from sun, unpacked, renamed and put 
into the right directory in the maven local repository in order to run the 
maven plugin. For JDK 1.4 and later, this is not necessary any more 
because the jars are already contained in the jdk.

I would like to comment out the dependency on jndi and jdbc in the 
generator's project xml and put a note 1) in the project xml itself and 2) 
on the generator homepage to uncomment the dependecies if one uses jdk 
1.3. This would imply that people using jdk 1.3 would have to build the 
generator from source.

Note that the runtime should still support JDK 1.3 out of the box 
(However, I am not sure about it because I did not try it lately)

Are there any objections, other suggestions etc ?

   Thomas



---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message