db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Bayet <ba...@enseirb.fr>
Subject Re: Village dependency
Date Fri, 12 Nov 2004 12:39:24 GMT
Vidas Simkus wrote:
> In reference to this:
> http://db.apache.org/torque/dependencies.html
> 
> It states that Torque requires '2.0-dev-20030825', yet there's no 
> reference to that particular version anywhere on the Village site.  I 
> checked out the latest version for their CVS...and the build.xml has 
> '2.0-dev' as the version property.  Is this the correct version of 
> Village to use?
> 
> Thanks
> 
I've been using village-2.0-dev-20030825 (shipping with either torque 
3.1 and torque-gen 3.1, I think) for months without problem on a given 
project, until I encountered a problem handling Peer objects of a table 
containing a 'Blob'.
I thought the problem was because my RDBMS is not officialy supported 
(FrontBase), but actually, the point was that this version of village 
didn't support 'NULL' Blobs.
I got the latest version from the CVS, did a slight patch in 
com.workingdogs.village.Value and everything runs fine now.

So I would say that as long as the '2.0-dev-20030825' is just somehow a 
'stable dev' release, you shoudn't have problem with a later '2.0-dev'.
Yet, I haven't used my modified version to re-generated my OM (that is, 
using Ant and the build.xml) since.

Regards

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message