db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henning Schmiedehausen <...@intermeta.de>
Subject [SOURCE] Issue #TRQS229 modified
Date Sat, 16 Oct 2004 10:47:51 GMT
You can view the issue detail at the following URL:

    http://nagoya.apache.org/scarab/issues/id/TRQS229

Type
 Defect

Issue ID
 TRQS229 (torque v3 1   commons configuration v1 0 don't play nice together)

Modified by
 Henning Schmiedehausen
 henning (hps@intermeta.de)

The following modifications were made to this issue:
---------------------------------------------------------------------

Status changed from "New" to "Closed"
Resolution set to "Wontfix"

Reason:
As listed by the error message, Commons Configuration 1.0 needs the o.a.commons.collections.map.LinkedMap
class which is not available before commons-collections-3.0.

This is properly reflected in the dependencies for the Torque-3.1.1-rc core, generator and
maven plugin.

If you upgrade one part of your project to a new jar, you must fulfill all the dependency
needs of this new jar. If you don't do this, you will get an error as listed above.

This is not a Torque error. If you are unsure which jar versions to use with Torque, please
stick with the versions listed in the project.xml file of your release.

(The introduction of "SNAPSHOT" dependencies and the subsequent check in of such dependencies
into the source repositories was IMHO the biggest mistake ever made by the Maven developers.
However, they didn't want to listen 18 months ago, they will not listen now either).

---------------------------------------------------------------------
This message is automatically generated by the Scarab
issue tracking system.  For more information:
http://scarab.tigris.org/



---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org


Mime
View raw message