db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Don O'Leary" <...@delads.com>
Subject Problems integrating Torque into existing environment
Date Fri, 20 Feb 2004 19:08:25 GMT
Hi

I am new to this forum.
I have run through the tutorial for Torque and everything worked great. Very powerful, and
looking forward to integrating this functionality into my existing environment.

In doing so, I have run into the following problems, building the tutorial example in my environment.


I am including "build-torque.xml" from my existing build.xml file, so I have had to remove
the outer <project> tags. Seems to work fine.
I have run into the following problems.

Problem 1
When running "ant id-table-init-sql" I get the following exception 
BUILD FAILED
file:./antinclude/build-torque.xml:399: The <torque-sql> task doesn't support the "useclasspath"
attribute.

I can see that this useClasspath attribute is to allow the dynamic lookup of templates from
the classpath, so torque can be used without extracting the jar.
I can live without this functionality for now, so when I remove the useClasspath from my ant
tasks, I get past this point.

Problem 2
The second problem is when I run the "ant insert-sql"

insert-sql:
[torque-sql-exec] Our new url -> jdbc:mysql://127.0.0.1/bookstore
[torque-sql-exec] Executing file: C:\cvslib\qa\src\sql\id-table-schema.sql
[torque-sql-exec] Executing file: C:\cvslib\qa\src\sql\bookstore-schema.sql
[torque-sql-exec] Executing file: C:\cvslib\qa\src\sql\bookstore-schema-idtable-
init.sql
[torque-sql-exec] Failed to execute: insert into ID_TABLE (id_table_id, table_na
me, next_id, quantity) VALUES ($initialID, 'book', $initialIDValue, $initialIDSt
ep)
[torque-sql-exec] java.sql.SQLException: Column not found,  message from server:
 "Unknown column '$initialID' in 'field list'"
[torque-sql-exec] Failed to execute: insert into ID_TABLE (id_table_id, table_na
me, next_id, quantity) VALUES ($initialID, 'publisher', $initialIDValue, $initia
lIDStep)
[torque-sql-exec] java.sql.SQLException: Column not found,  message from server:
 "Unknown column '$initialID' in 'field list'"
[torque-sql-exec] Failed to execute: insert into ID_TABLE (id_table_id, table_na
me, next_id, quantity) VALUES ($initialID, 'author', $initialIDValue, $initialID
Step)
[torque-sql-exec] java.sql.SQLException: Column not found,  message from server:
 "Unknown column '$initialID' in 'field list'"
[torque-sql-exec] 8 of 11 SQL statements executed successfully

BUILD SUCCESSFUL
Total time: 2 seconds



The database looks like it was created successfully, but I am worried I will run into problems
later on. I don't really want to be chasing my tail with issues if this is a configuration
issue integrating torque into an existing environment.

Any help would be very much appreciated.
Cheers

Don




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message