db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Kario <nos...@mermit.fi>
Subject Re: Torque build failure
Date Tue, 24 Jun 2003 10:52:24 GMT
Daniel Rall wrote:
> Janne <nospam@mermit.fi> writes:
> 
> 
>>***** /home/*****/tmp/db-torque >maven dist:lite
>>  __  __
>>|  \/  |__ Jakarta _ ___
>>| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
>>|_|  |_\__,_|\_/\___|_||_|  v. 1.0-beta-9-SNAPSHOT
>>
>>
>>Attempting to download commons-configuration-1.0-dev-3.20030607.194155.jar.
>>Error retrieving artifact from
>>[http://www.ibiblio.org/maven/commons-configuration/jars/commons-configuration-1.0-dev-3.20030607.194155.jar]:
>>java.lang.Exception: Can't get
>>commons-configuration-1.0-dev-3.20030607.194155.jar.incomplete to
>>/tmp/maven-1.0-beta-9/repository/commons-configuration/jars/commons-configuration-1.0-dev-3.20030607.194155.jar.incomplete
>>
>>WARNING: Failed to download
>>commons-configuration-1.0-dev-3.20030607.194155.jar.Attempting to
>>download commons-dbcp-SNAPSHOT.jar.
>>
>>......................................................
>>Attempting to download jdbc-2.0.jar.
>>Error retrieving artifact from
>>[http://www.ibiblio.org/maven/jdbc/jars/jdbc-2.0.jar]:
>>java.lang.Exception: Can't get jdbc-2.0.jar.incomplete to
>>/tmp/maven-1.0-beta-9/repository/jdbc/jars/jdbc-2.0.jar.incomplete
>>
>>WARNING: Failed to download jdbc-2.0.jar.
>>Attempting to download jndi-1.2.1.jar.
>>Error retrieving artifact from
>>[http://www.ibiblio.org/maven/jndi/jars/jndi-1.2.1.jar]:
>>java.lang.Exception: Can't get jndi-1.2.1.jar.incomplete to
>>/tmp/maven-1.0-beta-9/repository/jndi/jars/jndi-1.2.1.jar.incomplete
>>
>>WARNING: Failed to download jndi-1.2.1.jar.
>>The build cannot continue because of the following unsatisfied dependencies:
>>
>>commons-configuration-1.0-dev-3.20030607.194155.jar
>>jdbc-2.0.jar
>>jndi-1.2.1.jar
>>
>>Total time:  14 seconds
>>
>>
>>I checked http://www.ibiblio.org/maven repository and the above files
>>do not exists there.
> 
> 
> I had the same problem last week for (only)
> commons-configuration-1.0-dev-3.20030607.194155.jar.  I worked around
> it by adding the following to my project.properties:
> 
> maven.jar.override=on
> maven.jar.commons-configuration=1.0-dev

This solved problem with commons-configuration. jndi and jdbc to go. I 
guess this has gone unnoticed because developers seldom start with a 
clean maven repository just as I did. Who should I contact at ibiblio to 
get the missing libraries in place?

- Janne




Mime
View raw message