db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Age Mooy" <am...@home.nl>
Subject [torque-plugin patch] Classspath problems in torque:insert-sql
Date Mon, 07 Apr 2003 09:29:46 GMT
Hi,

I guess this is still the best place to submit patches for the Maven
Torque plugin...

I don't know if anyone has ever tested the torque:insert-sql goal in the
"new" torque plugin but it seems unlikely it ever worked. This goal (and
quite probably some others) need classpath access to the relevant JDBC
driver in order to execute the sql-exec task. JDBC drivers are usually
specified in the project dependencies but the torque plugin defines its
own classpath. This results in NoClasDefFound eceptions when trying to
use the torque:insert-sql goal.

I solved this by adding the Maven dependency classpath to the global
torque-classpath. I tested it locally with mysql and the mysql JDBC
driver.

Can someone please apply this patch ?

Thanks,
Age


Index: plugin.jelly
===================================================================
RCS file: /home/cvspublic/maven/src/plugins-build/torque/plugin.jelly,v
retrieving revision 1.3
diff -u -r1.3 plugin.jelly
--- plugin.jelly	24 Mar 2003 21:08:17 -0000	1.3
+++ plugin.jelly	7 Apr 2003 09:20:36 -0000
@@ -33,6 +33,7 @@
       <pathelement path="${plugin.getDependencyPath('xercesImpl')}"/>
       <pathelement
path="${plugin.getDependencyPath('xmlParserAPIs')}"/>
       <pathelement path="${plugin.getDependencyPath('torque-gen')}"/>
+      <path refid="maven.dependency.classpath"/>
     </path>
 
     <!-- The default.properties file will map old properties to the new
ones along



Mime
View raw message