db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Quinton McCombs" <qmcco...@nequalsone.com>
Subject Database connections not being released
Date Wed, 11 Dec 2002 16:29:56 GMT
I am having a problem with database connections not being released.  I
turn on the logging of the connection pool status and it says that there
are four pooled connections.  The database reports that there are 43
connections.
 
I am using T2.2 with the decoupled torque.  The database is Oracle.
 
Here is my Torque.properties file:
 
torque.database.default=default
torque.database.default.adapter=oracle
torque.dsfactory.default.factory=org.apache.torque.dsfactory.TorqueDataS
ourceFactory
torque.dsfactory.default.pool.defaultMaxConnections=10
torque.dsfactory.default.pool.maxExpiryTime=3600
torque.dsfactory.default.pool.connectionWaitTimeout=10
torque.dsfactory.default.pool.logInterval=60
torque.dsfactory.default.connection.driver=oracle.jdbc.driver.OracleDriv
er
torque.dsfactory.default.connection.url=jdbc:oracle:thin:@neo02.nequalso
ne.com:1521:DEV
torque.dsfactory.default.connection.user=******
torque.dsfactory.default.connection.password=******
torque.idbroker.cleverquantity=true
torque.manager.useCache = true

 
This is the log statement from the connection pool:
2002-12-11 10:28:07,055 [Thread-10] DEBUG
org.apache.torque.pool.ConnectionPool -
org.apache.torque.pool.ConnectionPool@be76c7 (in + out = total): 4 + 0 =
4
 
 
Any ideas?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message