db-ojb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jys <...@fr.st>
Subject Re: OJB 1.0.x and Java5.0
Date Sun, 07 Aug 2005 18:35:00 GMT
I'am using OJB with java 5, and haven't noticed any issues with it, 
because of runtime type erasure i guess. Except  for the xdoclet module 
that was patched i think to be able to parse Java 5 classes.

Jean-Yves

Thomas Dudziak wrote:

>On 8/7/05, Tino Schöllhorn <t.schoellhorn@plattform-gmbh.de> wrote:
>
>  
>
>>we are currently thinking of moving from JDK1.4.2 to Java 5.0.x. The
>>most interesting part of new Java Editition is the use of Generics which
>>will lead to a much better understandable code-base. I have a few
>>questions, which might be answered by someone of the OJB community:
>>
>>- Are there any known issues of using OJB 1.0.x with Java 5.0?
>>- If so, will OJB 1.1 work with Java 5.0?
>>- Does anyone use Java 5.0 in a production system?
>>    
>>
>
>AFAIK it does. In one of our projects we use Java5 as the development
>JDK (though the deployment platform is JDK 1.4.2), and it works
>without problems.
>I think that even generics work as they are compiled to normal
>generic-less bytecode anyway. I haven't tried them though.
>The only other Java5 feature that is relevant to OJB - enums - does
>not work yet. It might be easy but nobody has found the time to
>investigate yet.
>
>Tom
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: ojb-user-unsubscribe@db.apache.org
>For additional commands, e-mail: ojb-user-help@db.apache.org
>
>
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-user-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-user-help@db.apache.org


Mime
View raw message