db-ojb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert S. Sfeir" <rob...@codepuccino.com>
Subject Re: deploy OJB with web application
Date Mon, 16 Feb 2004 16:37:32 GMT
Thomas Dudziak wrote:

>On Mon, 16 Feb 2004, marc salvetti wrote:
>
>  
>
>>well in fact i don't have much choices as i don't control my host computer and 
>>resin versions
>>    
>>
>
>I wonder why this should have anything to do with resin ? From what you
>posted it seems more like a problem with the XML parser, as the
>isolation-level (which you probably didn't specify at first) wasn't
>read. If you don't specify an attribute value, the XML parser is supposed
>to fetch the default value from the DTD (if it exists), and if there is no
>default value (because e.g. it's CDATA) then a null is returned.
>So could it be that you either use an old repository.dtd (where there is
>no isolation-level attribute declared), or that the XML parser does not
>find the DTD (and is not configured to complain) ?
>You might want to try putting 'http://db.apache.org/ojb/repository.dtd' as
>the DTD location into your repository.xml.
>
>Tom
>
>  
>

Nope, I went through all that, clean install of everything, even outside 
my app.  Scott Ferguson at Caucho figured it out and fixed it.  It was 
the parser failing in a certain way, he's accounted for it.  That same 
setup working fine in Tomcat 5.

R

---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-user-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-user-help@db.apache.org


Mime
View raw message