db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chiah Tong Kiat" <...@silicomp.com.sg>
Subject Errors compiling 1.0.4 Branch using jdk 1.3
Date Mon, 13 Feb 2006 05:24:37 GMT
Hi 
 
Currently the 1.0.4 branch is generating the following compilation
errors.
 
main-opt:
    [javac] Compiling 599 source files to C:\Codes\c\target\classes
    [javac]
C:\Codes\c\target\src\org\apache\ojb\broker\locking\LockManagerInMemoryI
mpl.java:21: cannot resolve symbol
    [javac] symbol  : class LinkedHashMap
    [javac] location: package util
    [javac] import java.util.LinkedHashMap;
    [javac]                  ^
    [javac]
C:\Codes\c\target\src\org\apache\ojb\broker\ant\WriteDataToDatabaseComma
nd.java:85: valueOf(java.lang.String) in java.lang.Boolean cannot be
applied to (boolean)
    [javac]         _useBatchMode = Boolean.valueOf(useBatchMode);
    [javac]                                ^
    [javac]
C:\Codes\c\target\src\org\apache\ojb\broker\locking\LockManagerInMemoryI
mpl.java:51: cannot resolve symbol
    [javac] symbol  : class LinkedHashMap
    [javac] location: class
org.apache.ojb.broker.locking.LockManagerInMemoryImpl
    [javac]     private final Map resourceLockMap = new
LinkedHashMap(70);
    [javac]                                             ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -deprecation for details.
[javac] 3 errors
 
Looks like it's using some of the 1.4 classes.  Is there anyway we could
fix this issue?
 
Thanks
 
 

Mime
View raw message