db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Armin Waibel <arm...@apache.org>
Subject Re: [ODMG] Setting auto-xxx in class descriptors doesn't work
Date Tue, 12 Jul 2005 16:21:51 GMT
Hi Bart,

did you tried it with latest from CVS (1.0.x branch OJB_1_0_RELEASE)?
I fixed some bugs in ODMG implementation. E.g fixed problem OJB-33 
sounds similar
http://issues.apache.org/jira/browse/OJB-33

If you still have the problem, please describe your test case in detail, 
so that I'm able to set up a unit test.

regards,
Armin


Bart Molenkamp wrote:
> Hi,
> 
> The ODMG manual [1] says that it's required to configure specific
> metadata settings. When setting these, m:n relationships won't get
> stored when inserting objects in the database (using
> Database.makePersistent). When not setting these auto-xxx settings (and
> leaving them default), m:n relationships do get stored.
> 
> This is only when inserting objects into the database; updating existing
> objects from the database works well.
> 
> Is this a bug, or is this the expected behaviour of the ODMG spec?
> 
> Thanks,
> Bart.
> 
> [1]
> http://db.apache.org/ojb/docu/guides/odmg-guide.html#Specific+Metadata+S
> ettings
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
> For additional commands, e-mail: ojb-dev-help@db.apache.org
> 
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-dev-help@db.apache.org


Mime
View raw message