db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: Postgresql junit test results
Date Wed, 19 Jan 2005 06:06:09 GMT
Hi Phil:

Yep. I noted the same result in PostgreSQL. I am using version PostgreSQL
7.4.6. The DROP tables I guess is not a big trouble since you just created
the database so there don't exists the tables that the test wanted to drop
before create a new one.

But I had a problem trying to create some of the tables:

......
Failed to execute: CREATE TABLE PERF_ARTICLE ( ARTICLE_ID integer NOT
NULL, ARTICLE_NAME varchar (150), MINIMUM_STOCK integer, PRICE double,
UNIT varchar (20), STOCK integer, SUPPLIER_ID integer, PRODUCT_GROUP_ID
integer, PRIMARY KEY (ARTICLE_ID) )
[torque-sql-exec] org.postgresql.util.PSQLException: ERROR: no existe el
tipo "double"
...........
Failed to execute: CREATE TABLE REF_ANIMAL ( A_ID integer NOT NULL, NAME
varchar (100), CLASS_NAME varchar (100), LENGTH_ double, PRIMARY KEY
(A_ID) )
..........
383 of 564 SQL statements executed successfully

And this tables could create some of the troubles. This is why I asked to
an torque update in a hope that this could solve the problems. ;-)

On Mar, 18 de Enero de 2005, 17:36, Philip Mark Donaghy dijo:
> Armin, Antonio,
>
> Excellent, "ant junit" was SUCCESSFUL. I had to change
> the tcp_socket variable to true in
> /var/lib/pgsql/data/postgresql.conf to get postgres to
> accept jdbc connections and uncomment the line "host
> all all 127.0.0.1 255.255.255.255 trust" in
> /var/lib/pgsql/data/pg_hba. I also messed around with
> the command "createuser". I had to add the variable
> databaseHost to profile/postgresql.profile.
>
> Ant reports many DROP errors,
>
> [torque-sql-exec] Failed to execute: DROP TABLE
> OJB_HL_SEQ CASCADE
> [torque-sql-exec] org.postgresql.util.PSQLException:
> ERROR: table "ojb_hl_seq" does not exist
>
> The test files are not attached because they are too
> big. Here is a summary,
>

I receive diferents results as you:

> target/test/tests-broker.txt:Tests run: 614, Failures:
> 3, Errors: 9, Time elapsed: 77.456 sec

Tests run: 524, Failures: 4, Errors: 5, Time elapsed: 132.547 sec

> target/test/tests-odmg.txt:Tests run: 131, Failures:
> 0, Errors: 2, Time elapsed: 9.822 sec

Tests run: 129, Failures: 1, Errors: 4, Time elapsed: 22.3 sec

> target/test/tests-otm.txt:Tests run: 79, Failures: 1,
> Errors: 3, Time elapsed: 12.424 sec

Tests run: 79, Failures: 0, Errors: 0, Time elapsed: 19.575 sec

> target/test/tests-soda.txt:Tests run: 3, Failures: 0,
> Errors: 0, Time elapsed: 1.737 sec

Same here.

My run was against the OJB-1.0.x CVS.

Best Regards,

Antonio Gallardo

>
> Thanks,
>
> Phil
>
>
>
> __________________________________
> Do you Yahoo!?
> Yahoo! Mail - now with 250MB free storage. Learn more.
> http://info.mail.yahoo.com/mail_250
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
> For additional commands, e-mail: ojb-dev-help@db.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-dev-help@db.apache.org


Mime
View raw message