db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Dudziak <tom...@gmail.com>
Subject Using cglib when running under JDK1.2
Date Tue, 25 Jan 2005 20:08:51 GMT
While I was enhancing the environment check for building OJB with
(hopefully) helpful error messages, I stumbled across the Proxy
replacement classes that are used when OJB is used with JDK 1.2.
Because I wanted to provide a download url in the error message when
these classes are not present during the build with JDK 1.2, I
searched the web for them but could not find them anywhere.
Since cglib provides the same functionality for JDK 1.2, I decided to
replace the custom Proxy replacement classes with the cglib ones. I
refrained however from adding the cglib jar to OJB as it is rarely
needed (few people use OJB with JDK 1.2).
Please let me know if this replacement is a problem.

regards,
Tom

---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-dev-help@db.apache.org


Mime
View raw message