db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mahler Thomas <thomas.mah...@itellium.com>
Subject RE: [OJB1.1] J2SE 1.4 as minimum requirement for OJB 1.1?
Date Fri, 01 Oct 2004 13:19:44 GMT
Hi Armin,

I agree, it's a pain to support all these platforms.
And I think it was the right step to drop the JDK 1.2 compatibility.

But JDK 1.3 is still around in a lot of production environments.
And supporting 1.3 is much less pain then 1.2 where we had to merge in our
own proxy replacement.

So I think OJB 1.0.x should continue to support 1.3.

But I guess it makes sense to shift to 1.4 for OJB1.1

so I'm +1 for your suggestion,

Thomas




> -----Original Message-----
> From: Armin Waibel [mailto:arminw@apache.org]
> Sent: Friday, October 01, 2004 2:31 PM
> To: OJB Developers List
> Subject: [OJB1.1] J2SE 1.4 as minimum requirement for OJB 1.1?
> 
> 
> Hi all,
> 
> after seeing a similar thread in Forrest I thought about this 
> for OJB1.1.
> J2SE 5.0 is released and J2SE1.4 is more than 2 years (August 2002?) 
> old. The time frame for OJB1.1 is end of this year (beginning 
> of 2005).
> 
> So wouldn't it be reasonable to use J2SE 1.4 as minimum 
> requirement for 
> OJB1.1 (JDK 1.3 was released in 2000)? Should we really 
> support a 5 year 
> old JVM in OJB1.1? Or need OJB user in year 2005 further on 
> support for 
> JDK1.3?
> 
> regards,
> Armin
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
> For additional commands, e-mail: ojb-dev-help@db.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-dev-help@db.apache.org


Mime
View raw message