db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Dudziak <to...@first.fhg.de>
Subject Re: J2EE 1.3/1.4 SCSL Geronimo Etc
Date Wed, 15 Sep 2004 13:29:03 GMT
Brian McCallister wrote:

> A user discovered that the source build of OJB 1.0.1 doesn't work 
> under java 1.3 right now. Apparently the geronimo-spec j2ee jars are 
> jdk 1.4 dependent.
>
> Replacing the geronimo jars with the SCSL j2ee.jar allows build to 
> proceed normally.
>
> Thoughts on best way to handle?
>
> I would tend towards leaving the geronimo spec jars in by default, but 
> including docs on building under 1.3 and getting the SCSL jars. I tend 
> to be aggressive though, and 1.0.X is a maintenance branch so...

+1 for leaving the Geronimo jars in place.

Also, the build script can use the available information about the used 
JDK to ignore these jars when building under JDK 1.2/1.3, so that the 
old behavior is present again in this case (it could even utter a note 
that these jars are needed and where to get them).

Tom


---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-dev-help@db.apache.org


Mime
View raw message