db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Armin Waibel <arm...@apache.org>
Subject Re: New Service IdentityFactory
Date Tue, 06 Jul 2004 10:52:38 GMT
maybe we should rename the method names from

IdentityFactory#buildIdentity(...)

to

IdentityFactory#build(...)
or
IdentityFactory#create(...)

the appendix "Identity" in method name is redundant.


Armin

Armin Waibel wrote:

> Hi all,
> 
> I committed the first version of the new IdentityFactory service. IF 
> make the building of Identity objects much more easier.
> For example to get the Identity of an object using a single Long PK 
> value you can call:
> 
> Identity oid = broker.serviceIdentity().buildIdentity(MyClass.class, new 
> Long(23));
> result = broker.getObjectByIdentity(oid);
> 
> comments are welcome.
> 
> regards,
> Armin
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
> For additional commands, e-mail: ojb-dev-help@db.apache.org
> 
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-dev-help@db.apache.org


Mime
View raw message