db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Armin Waibel <ar...@code-au-lait.de>
Subject Re: Upgrade to commons-collections 3.0?
Date Tue, 27 Jan 2004 10:12:09 GMT
Hi,

the question is, were do we use commons-collection in OJB
(OJB main classes)?
There is currently one class using commons-collection:
PersistentFieldAutoProxyImpl
This class using FastHashMap. FastHashMap should be 2.x/3.x compatible, 
because there was no package renaming for this class. So, OJB runtime 
jar should work with both versions of commons-collection.

I propose to upgrade when most other popular projects (Torque, XDoclet, 
Tomcat, Struts?, ...) use new commons-collection version (to avoid 
side-effects with these used libraries).

In any case I propose to add a note in release notes, says that OJB is 
compatible with both versions.

regards,
Armin

Antonio Gallardo wrote:
> Thomas Dudziak dijo:
> 
>>I would be extra careful with changing the commons stuff. There's a lot of
>>projects using them (e.g. Torque, Tomcat (?), XDoclet), so we should check
>>whether there are any signifcant changes (there should be a reason that is
>>a new major version number), and how they affect not only OJB but also
>>these other projects.
> 
> 
> Hi Thomas:
> 
> I understand your concerns. If this help, I can said, it is already
> running in Tomcat 4.1.29 and Cocoon 2.1.4-dev and no problems reported at
> all.
> 
> Best Regards,
> 
> Antonio Gallardo
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
> For additional commands, e-mail: ojb-dev-help@db.apache.org
> 
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-dev-help@db.apache.org


Mime
View raw message