db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agsoftware.dnsalias.com>
Subject CVS problem compiling with JDO 1.0 or 1.01
Date Sun, 23 Nov 2003 22:02:42 GMT
Hi:

I just updated the CVS, first I did a build.sh clean. Then I tried to
compiled with the JDO 1.0 and of course there was some problems (related
to changes in the CVS).

I downloaded JDO 1.01 and I still cannot compile it. Here are the problems:

main-opt:
    [javac] Compiling 591 source files to /db-ojb/target/classes
    [javac]
/db-ojb/target/src/org/apache/ojb/jdo/PersistenceManagerImpl.java:74:
org.apache.ojb.jdo.PersistenceManagerImpl is not abstract and does not
override abstract method retrieveAll(java.lang.Object[],boolean) in
javax.jdo.PersistenceManager
    [javac] public class PersistenceManagerImpl implements PersistenceManager
    [javac]        ^
    [javac]
/db-ojb/target/src/org/apache/ojb/jdo/PersistenceManagerFactoryImpl.java:68:
org.apache.ojb.jdo.PersistenceManagerFactoryImpl is not abstract and
does not override abstract method close() in
javax.jdo.PersistenceManagerFactory
    [javac] public class PersistenceManagerFactoryImpl implements
PersistenceManagerFactory
    [javac]        ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -deprecation for details.
    [javac] 2 errors

BUILD FAILED
file:/db-ojb/build.xml:252: Compile failed; see the compiler error output
for details.

Total time: 1 minute 10 seconds

Best Regards,

Antonio Gallardo

---------------------------------------------------------------------
To unsubscribe, e-mail: ojb-dev-unsubscribe@db.apache.org
For additional commands, e-mail: ojb-dev-help@db.apache.org


Mime
View raw message