db-ojb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Mahler <t...@apache.org>
Subject Re: for oracle lobs, can we require jdk1.4?
Date Sun, 15 Dec 2002 09:22:23 GMT
Hi Michael,

There are several users that rely on JDK1.2 and JDK1.3.
So Making JDK1.4 a prerequisite is not an option!

We currently use a preprocessor to compile stuff against the latest JDBC 
3.0 API.
Scan the sources for //#ifdef JDBC30 to get an idea how it can be used.

IANAL, but it's obvious that we can not include Oracle code or jar files 
in our distribution for legal reasons!

cheers,
Thomas

Michael Mogley wrote:
 > It seems jdk1.3 doesn't even have the needed
 > PreparedStatement.setXXXStream methods.  If I can get things to work
 > with the jdk1.4 methods and we make jdk1.4 a prerequisite to getting
 > full use out of the jdbc driver, then we'll be able to avoid having
 > to import oracle classes into the project.  Thoughts?
 >
 > Michael



Mime
View raw message