db-jdo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leschke Scott-NVCX76" <scott.lesc...@motorola.com>
Subject RE: JDO2 API's manifest file problem with Apache Felix
Date Thu, 24 Jul 2008 00:22:33 GMT
 
I noticed that the jdo2 api jar isn't recognized in Eclipse v3.4
(Ganymeede) while it is in v3.3. My guess is that it's the same issue.

Scott

-----Original Message-----
From: Raymond Lai [mailto:airwave209gt@gmail.com] 
Sent: Wednesday, July 23, 2008 6:38 PM
To: jdo-user@db.apache.org
Subject: JDO2 API's manifest file problem with Apache Felix


Hi there,

As per discussion on

http://www.nabble.com/Is-it-a-bug--Felix-cannot-parse-Bundle-ManifestVer
sion-having-trailing-spaces-td18613664.html#a18617865

While they had committed a fix to Felix, the people there suggests it's
also the problem of the JDO2 API's jar file - more specifially, is this
line:

Bundle-ManifestVersion: 2 

The trailing space after 2 was causing the problem that made JDO2 API
cannot be started on Apache Felix as an OSGi bundle.

Would the people working on the JDO spec fix this line?

TIA,
Raymond
--
View this message in context:
http://www.nabble.com/JDO2-API%27s-manifest-file-problem-with-Apache-Fel
ix-tp18622812p18622812.html
Sent from the JDO - User mailing list archive at Nabble.com.


Mime
View raw message