db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Bouschen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JDO-724) Move to using JPA2.1 API jar in TCK
Date Mon, 13 Jan 2014 08:55:54 GMT

    [ https://issues.apache.org/jira/browse/JDO-724?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13869363#comment-13869363
] 

Michael Bouschen commented on JDO-724:
--------------------------------------

I applied the patch (before the latest checkin) and successfully ran the tck.

I noticed a difference in copyjdorijars/pom.xml: the patch uses version 3.3.6 of datanucleus-api-jpa,
the version checked in uses 3.3.5.



> Move to using JPA2.1 API jar in TCK
> -----------------------------------
>
>                 Key: JDO-724
>                 URL: https://issues.apache.org/jira/browse/JDO-724
>             Project: JDO
>          Issue Type: Task
>          Components: tck
>            Reporter: Andy Jefferson
>            Assignee: Andy Jefferson
>            Priority: Minor
>             Fix For: JDO 3 maintenance release 1 (3.1)
>
>         Attachments: JDO-724.svn.diff
>
>
> JPA 2.1 is apparently "released" and implementations will increasingly allow its use.
The jar used by Apache JDO TCK for the JPA API will need updating to reflect this
> Sadly
> 1. The people behind JSR0338 (JPA 2.1) haven't released an official JPA API jar for v2.1.
See https://java.net/jira/browse/JPA_SPEC-60
> 2. Apache Geronimo is still to release a "specs" jar for JPA 2.1. Even though they mark
https://issues.apache.org/jira/browse/GERONIMO-6451  as fixed, the result is not public



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message