db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michelle Caisse <mcai...@sonic.net>
Subject Re: gpg help, please
Date Thu, 27 Jun 2013 18:45:41 GMT
Thanks for the replies. I think I didn't provide enough information. 
When I run mvn clean install -Papache-release, it prompts me for my gpg 
passphrase and I enter it on the command line, where it is masked. After 
that it gives the error. I think the problem is that, after 5 years and 
several computer and OS upgrades,  I've lost my private key. I will need 
to create a new key.

-- Michelle

On 6/24/2013 9:12 PM, Andy Jefferson wrote:
>> I haven't tried this particular profile. The only thing I can think of is
>> that you need to have some other command line parameter to allow maven to
>> get your private (key) password.
>> You cannot pass your password on the command line because anyone who does
>> ps-ef can see your password in the plain. So it has to be some file or you
>> type it into the maven command.
>> It may be that you need to configure the nexus repository to do this.
> I use the Maven release plugin to release DataNucleus and following the
> Sonatype guide(s) I ended up editing the users ".m2/settings.xml" with
> (something like)
>      <profiles>
>          <profile>
>              <id>development</id>
>              <properties>
>                  <gpg.passphrase>YOURPASSPHRASE</gpg.passphrase>
>              </properties>
>          </profile>
>      </profiles>
>      <activeProfiles>
>          <activeProfile>development</activeProfile>
>      </activeProfiles>
> and so I never have to enter the passphrase at release. HTH

View raw message