db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Jefferson (JIRA)" <j...@apache.org>
Subject [jira] Updated: (JDO-649) Upgrade "persistence.xml" for use with TCK to be JPA2 since DataNucleus 2.x uses that now
Date Mon, 16 Nov 2009 15:51:39 GMT

     [ https://issues.apache.org/jira/browse/JDO-649?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andy Jefferson updated JDO-649:
-------------------------------

    Description: 
DataNucleus builds against JPA2 specification now so need to upgrade the "geronimo-specs"
dependency. Was previously

<dependency>
    <groupId>org.apache.geronimo.specs</groupId>
    <artifactId>geronimo-jpa_3.0_spec</artifactId>
    <version>1.0</version>
</dependency>

and should be

<dependency>
    <groupId>org.apache.geronimo.specs</groupId>
    <artifactId>geronimo-jpa_2.0_spec</artifactId>
    <version>1.0-PFD2</version>
</dependency>

No idea why geronimo specs thinks JPA1 is "JPA 3.0" but anyway ...

  was:DataNucleus builds against JPA2 specification now so need to upgrade the "geronimo-specs"
dependency


> Upgrade "persistence.xml" for use with TCK to be JPA2 since DataNucleus 2.x uses that
now
> -----------------------------------------------------------------------------------------
>
>                 Key: JDO-649
>                 URL: https://issues.apache.org/jira/browse/JDO-649
>             Project: JDO
>          Issue Type: Task
>          Components: tck2
>            Reporter: Andy Jefferson
>            Assignee: Andy Jefferson
>             Fix For: JDO 2 maintenance release 3
>
>
> DataNucleus builds against JPA2 specification now so need to upgrade the "geronimo-specs"
dependency. Was previously
> <dependency>
>     <groupId>org.apache.geronimo.specs</groupId>
>     <artifactId>geronimo-jpa_3.0_spec</artifactId>
>     <version>1.0</version>
> </dependency>
> and should be
> <dependency>
>     <groupId>org.apache.geronimo.specs</groupId>
>     <artifactId>geronimo-jpa_2.0_spec</artifactId>
>     <version>1.0-PFD2</version>
> </dependency>
> No idea why geronimo specs thinks JPA1 is "JPA 3.0" but anyway ...

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message