db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Jefferson <a...@datanucleus.org>
Subject M2 repo error
Date Mon, 16 Mar 2009 09:15:57 GMT
On  http://mirrors.ibiblio.org/pub/mirrors/maven2/javax/jdo/jdo2-api/
there is a file
http://mirrors.ibiblio.org/pub/mirrors/maven2/javax/jdo/jdo2-api/maven-metadata.xml
which is presumably used by Maven(2) in determining what versions it is 
prepared to let the world know about. There is no 2.2 entry in it, nor 2.1 
for that matter.

Means that whenever anyone specifies to use "apache-jdo" (javax.jdo/jdo2-api) 
between 2.2 and 3.0 they get the really informative

Couldn't find a version in [SNAPSHOT, 2.0-beta, 2.0-rc1, 2.0, 2.1-SNAPSHOT] to 
match range [2.2,3.0)
  javax.jdo:jdo2-api:jar:null


Perhaps there's someone who can fix this ?

Regards
-- 
Andy  (DataNucleus - http://www.datanucleus.org)

Mime
View raw message