db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JDO-612) M2 pom is incorrect, result in problems with transitive dependencies
Date Fri, 14 Nov 2008 17:34:46 GMT

    [ https://issues.apache.org/jira/browse/JDO-612?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12647673#action_12647673
] 

Carlos Sanchez commented on JDO-612:
------------------------------------

Michelle Caisse added the files to the apache Maven 1 repository, that is converted to Maven
2 and propagated to the central maven repository and mirrors

Unfortunately there's no easy way to fix it as it has been propagated to all mirrors, downstream
users,... already. You could either do a new official release (2.2.1, 2.2.0.1, ...) or just
copy the jar and the good pom as 2.2-1 (naming convention used before to fix bad poms with
the same jar)

> M2 pom is incorrect, result in problems with transitive dependencies
> --------------------------------------------------------------------
>
>                 Key: JDO-612
>                 URL: https://issues.apache.org/jira/browse/JDO-612
>             Project: JDO
>          Issue Type: Bug
>          Components: api2
>            Reporter: Andy Jefferson
>             Fix For: JDO 2 maintenance release 3
>
>
> jdo2-api.jar is in an M2 repository
> http://mirrors.ibiblio.org/pub/mirrors/maven2/javax/jdo/jdo2-api/2.2/
> and the pom has
> <dependencies>
>     <dependency>
>       <groupId>javax.transaction</groupId>
>       <artifactId>transaction-api</artifactId>
>       <version>1.1</version>
>     </dependency>
>     <dependency>
>       <groupId>org.apache.ant</groupId>
>       <artifactId>ant</artifactId>
>       <version>1.7.0</version>
>     </dependency>
>     <dependency>
>       <groupId>junit</groupId>
>       <artifactId>junit</artifactId>
>       <version>3.8.1</version>
>     </dependency>
>     <dependency>
>       <groupId>org.apache.geronimo.specs</groupId>
>       <artifactId>geronimo-jpa_3.0_spec</artifactId>
>       <version>1.0</version>
>     </dependency>
>   </dependencies>
> which is incomplete. All of these dependencies should be scoped to compile AFAICS. The
"junit" dep should be <scope>test</scope> since it is only for tests.
> Since jdo2-api.jar is not built using M2 and has no such M2 pom.xml where is this POM
coming from ? (some automated Maven process to convert M1 poms to M2 poms?)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message